文章目录

最近继续在研究react-native,不过时间相当少,进度也非常慢。今天在安装react-redux的时候碰到一个问题,如下:

1
2
3
4
5
6
+-- react-redux@5.0.5
`-- UNMET DEPENDENCY redux@^3.5.2
npm WARN react-redux@5.0.5 requires a peer of redux@^2.0.0 || ^3.0.0 but none was installed.

很奇怪,因为感觉这些东西都相对成熟了,怎么还会出现依赖问题呢?

Google了一下,解决方法在此:https://github.com/poetic/meteor-reacterminator/issues/33

大概描述一下:

1、打开package.json,在依赖部分写入

1
2
3
"redux": "^3.5.2"

2、命令行进入项目,输入下面命令单独安装redux

1
2
3
$npm install --save redux

3、再次安装react-redux

1
2
3
$npm install --save react-redux

完工!

♦ 本文固定连接:http://gsgundam.com/2017-06-07-react-redux-none-was-installed/

♦ 转载请注明:GSGundam 2017年06月07日发布于 GSGUNDAM砍柴工

友荐云推荐